summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-05-04 21:19:59 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-05-04 21:22:44 +0200
commita0352751ac2da3e961b0be7a175f9d9794d165f3 (patch)
treec433a725b92f9ea20377d6683c12780716ffa97b
parenta657cf77ead0bc69ea16580fe8da4441db34e4b1 (diff)
package: set CXX to false rather than "" if no C++ support is enabled
Some configure scripts seems to ignore CXX settings if it is set to the empty string, and goes back to the default (<arch>-linux-g++), so use false instead, as that will loudly break the build if the C++ compiler is ever used. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 2605639c9..7daa3b404 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -371,7 +371,7 @@ DISABLE_IPV6= --disable-ipv6
endif
ifneq ($(BR2_GCC_CROSS_CXX),y)
-TARGET_CONFIGURE_OPTS+=CXX=""
+TARGET_CONFIGURE_OPTS+=CXX=false
endif
ifeq ($(BR2_ENABLE_DEBUG),y)