summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThiago A. CorrĂȘa <thiago.correa@gmail.com>2009-04-06 22:56:20 +0000
committerThiago A. CorrĂȘa <thiago.correa@gmail.com>2009-04-06 22:56:20 +0000
commita933ef66bfd34b4d1c484f08da914e2626bb5a5e (patch)
tree8b7c66153a0ee74cd53d6966feb3708a30b5b88b
parentff33fbe880866ac8fefc15d779730efa71d1b80a (diff)
Fix compile for Qt Embedded (qtopia4) based packages
-rw-r--r--package/qtopia4/qtopia4.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index 9ae065fad..37bf27883 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -324,6 +324,8 @@ BR2_PACKAGE_QTOPIA4_EMB_PLATFORM:=$(strip $(subst ",, $(BR2_PACKAGE_QTOPIA4_EMB_
QTOPIA4_QMAKE_CONF:=$(QTOPIA4_TARGET_DIR)/mkspecs/qws/linux-$(BR2_PACKAGE_QTOPIA4_EMB_PLATFORM)-g++/qmake.conf
+QTOPIA4_QMAKE_AR:=$(TARGET_AR) cqs
+
# Variable for other Qt applications to use
QTOPIA4_QMAKE:=$(STAGING_DIR)/usr/bin/qmake -spec qws/linux-$(BR2_PACKAGE_QTOPIA4_EMB_PLATFORM)-g++
@@ -366,7 +368,7 @@ endif
$(call QTOPIA4_QMAKE_SET,CXX,$(TARGET_CXX))
$(call QTOPIA4_QMAKE_SET,LINK,$(TARGET_CXX))
$(call QTOPIA4_QMAKE_SET,LINK_SHLIB,$(TARGET_CXX))
- $(call QTOPIA4_QMAKE_SET,AR,$(TARGET_AR))
+ $(call QTOPIA4_QMAKE_SET,AR,$(QTOPIA4_QMAKE_AR))
$(call QTOPIA4_QMAKE_SET,OBJCOPY,$(TARGET_OBJCOPY))
$(call QTOPIA4_QMAKE_SET,RANLIB,$(TARGET_RANLIB))
$(call QTOPIA4_QMAKE_SET,STRIP,$(TARGET_STRIP))