summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Persson <spambox@nurd.se>2009-05-19 14:22:48 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-05-19 14:22:48 +0200
commitab59a44160f2391f2dbfac05d898283ad108a599 (patch)
tree25beeda714e7aac130df1d7f7cd0af8ec8356a55
parenta7ed91a957000fc16fd85720c70fb2e4561e1433 (diff)
mesa: fix build for x86
mesa wants to compile and run gen_matypes at build time, so make sure it gets compiled for the host and not for the target. Closes #323. Signed-off-by: Jim Persson <spambox@nurd.se> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/x11r7/mesa3d/mesa3d-gen_matypes-fix.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/x11r7/mesa3d/mesa3d-gen_matypes-fix.patch b/package/x11r7/mesa3d/mesa3d-gen_matypes-fix.patch
new file mode 100644
index 000000000..caa8b3141
--- /dev/null
+++ b/package/x11r7/mesa3d/mesa3d-gen_matypes-fix.patch
@@ -0,0 +1,12 @@
+diff -ruN Mesa-7.2.orig/src/mesa/x86/Makefile Mesa-7.2/src/mesa/x86/Makefile
+--- Mesa-7.2.orig/src/mesa/x86/Makefile 2008-08-25 16:46:47.000000000 +0200
++++ Mesa-7.2/src/mesa/x86/Makefile 2009-05-08 08:46:34.000000000 +0200
+@@ -21,7 +21,7 @@
+
+
+ gen_matypes: gen_matypes.c
+- $(CC) $(INCLUDE_DIRS) $(CFLAGS) gen_matypes.c -o gen_matypes
++ $(CC_FOR_BUILD) $(INCLUDE_DIRS) $(CFLAGS_FOR_BUILD) gen_matypes.c -o gen_matypes
+
+ # need some special rules here, unfortunately
+ matypes.h: ../main/mtypes.h ../tnl/t_context.h gen_matypes