summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-27 11:54:35 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-27 11:54:35 +0200
commit072d89a883c19dc2f69742c65eae7b4cf81b1f63 (patch)
tree0636cc47c26756bf5326e13aaa5008a6f8f53d89
parent2845fa66ce8efcf4a48a31e93832325ac1628cf1 (diff)
qt: fix build with external toolchain
Set QMAKE_LFLAGS so that at link time --sysroot is passed to the linker, and Qt finds the external libraries. This fixes Qt build when zlib or other libraries are external, instead of using Qt's internal copy. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/qt/qt.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index e07457e4c..ea59b0764 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -448,6 +448,7 @@ endif
$(call QT_QMAKE_SET,STRIP,$(TARGET_STRIP))
$(call QT_QMAKE_SET,CFLAGS,$(TARGET_CFLAGS))
$(call QT_QMAKE_SET,CXXFLAGS,$(TARGET_CXXFLAGS))
+ $(call QT_QMAKE_SET,LFLAGS,$(TARGET_LDFLAGS))
-[ -f $(QT_QCONFIG_FILE) ] && cp $(QT_QCONFIG_FILE) \
$(QT_TARGET_DIR)/$(QT_QCONFIG_FILE_LOCATION)
# Qt doesn't use PKG_CONFIG, it searches for pkg-config with 'which'.