summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-07-29 21:49:45 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-07-29 21:49:45 +0200
commit2a966bcd3bbf0323add5bc5426107bb3af24767d (patch)
tree4316f47e800bc633233cd7bd7a353f91587dad95
parent7a1a334c4216e2d105ceb6b2eceaa8986627ae67 (diff)
openssl: fix arch handling
Closes #497 Use ARCH instead of BR2_ARCH as BR2_ARCH won't match because of the surrounding quotes. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES1
-rw-r--r--package/openssl/openssl.mk8
2 files changed, 5 insertions, 4 deletions
diff --git a/CHANGES b/CHANGES
index 77c4398fc..c1bfe38a9 100644
--- a/CHANGES
+++ b/CHANGES
@@ -46,6 +46,7 @@
#451: Upgrade from unmaintained dosfstools-2.11 to dosfstools-3.0.3
#467: DirectFB 1.4.1
#473: memstat_0.5.tar.gz has install with -D and that fails "make"
+ #497: OpenSSL RSA key generation hangs on x86_64
2009.05, Released June 1st, 2009:
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index a0e6f7e54..16938f47f 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -9,16 +9,16 @@ OPENSSL_SITE:=http://www.openssl.org/source
OPENSSL_TARGET_ARCH=generic32
# Some architectures are optimized in OpenSSL
-ifeq ($(BR2_ARCH),avr32)
+ifeq ($(ARCH),avr32)
OPENSSL_TARGET_ARCH=avr32
endif
-ifeq ($(BR2_ARCH),ia64)
+ifeq ($(ARCH),ia64)
OPENSSL_TARGET_ARCH=ia64
endif
-ifeq ($(BR2_ARCH),powerpc)
+ifeq ($(ARCH),powerpc)
OPENSSL_TARGET_ARCH=ppc
endif
-ifeq ($(BR2_ARCH),x86_64)
+ifeq ($(ARCH),"x86_64")
OPENSSL_TARGET_ARCH=x86_64
endif