summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-28 11:24:10 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-28 11:53:04 +0200
commit90a459ce4d27fc6a2527ae29f0a07f24f0993a02 (patch)
tree2c9bca938b312ff7578802d6c710c9607b3a4e04
parent930f3db16724f95ebcf641d2887bb773f296c295 (diff)
xorg: add a new cross-compile fix for libXt 1.0.6
The cross-compile fix included in mainline of libXt between 1.0.5 and 1.0.6 is not sufficient. It allows to pass a different compiler for the host tools, but still uses the TARGET_CFLAGS/TARGET_LDFLAGS to compile the host tools, which obviously isn't correct. The new patch allows to use the CFLAGS_FOR_BUILD/LDFLAGS_FOR_BUILD variables as the CFLAGS/LDFLAGS to build the host tools. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/x11r7/xlib_libXt/xlib_libXt-1.0.6-cross-compile-fix.patch28
-rw-r--r--package/x11r7/xlib_libXt/xlib_libXt.mk3
2 files changed, 30 insertions, 1 deletions
diff --git a/package/x11r7/xlib_libXt/xlib_libXt-1.0.6-cross-compile-fix.patch b/package/x11r7/xlib_libXt/xlib_libXt-1.0.6-cross-compile-fix.patch
new file mode 100644
index 000000000..f02edcb6f
--- /dev/null
+++ b/package/x11r7/xlib_libXt/xlib_libXt-1.0.6-cross-compile-fix.patch
@@ -0,0 +1,28 @@
+diff --git a/configure.ac b/configure.ac
+index 043ab5f..cb00a41 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -48,6 +48,10 @@ if test x"$CC_FOR_BUILD" = x; then
+ fi
+ fi
+ AC_SUBST([CC_FOR_BUILD])
++CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
++AC_SUBST(CFLAGS_FOR_BUILD)
++LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
++AC_SUBST(LDFLAGS_FOR_BUILD)
+
+ PKG_CHECK_MODULES(XT, sm x11 xproto kbproto)
+
+diff --git a/util/Makefile.am b/util/Makefile.am
+index 0d3ff01..37b78d2 100644
+--- a/util/Makefile.am
++++ b/util/Makefile.am
+@@ -5,6 +5,8 @@ noinst_PROGRAMS = makestrs
+ endif
+
+ CC = @CC_FOR_BUILD@
++CFLAGS = @CFLAGS_FOR_BUILD@
++LDFLAGS = @LDFLAGS_FOR_BUILD@
+
+ EXTRA_DIST = \
+ Shell.ht \
diff --git a/package/x11r7/xlib_libXt/xlib_libXt.mk b/package/x11r7/xlib_libXt/xlib_libXt.mk
index 13e43c1bf..2fcf88916 100644
--- a/package/x11r7/xlib_libXt/xlib_libXt.mk
+++ b/package/x11r7/xlib_libXt/xlib_libXt.mk
@@ -7,7 +7,8 @@
XLIB_LIBXT_VERSION = 1.0.6
XLIB_LIBXT_SOURCE = libXt-$(XLIB_LIBXT_VERSION).tar.bz2
XLIB_LIBXT_SITE = http://xorg.freedesktop.org/releases/individual/lib
-XLIB_LIBXT_AUTORECONF = NO
+XLIB_LIBXT_AUTORECONF = YES
+XLIB_LIBXT_LIBTOOL_PATCH = NO
XLIB_LIBXT_INSTALL_STAGING = YES
XLIB_LIBXT_DEPENDENCIES = xlib_libSM xlib_libX11 xproto_kbproto xproto_xproto xcb-proto libxcb
XLIB_LIBXT_CONF_ENV = CC_FOR_BUILD="/usr/bin/gcc -I$(STAGING_DIR)/usr/include"