summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-11-23 11:03:27 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2009-11-23 11:03:27 +0100
commite189fe1f78f5dba0f642ce146b4b227415d09337 (patch)
tree1da94a1d5096042683f4bf58362101f41b9914fd
parent8fb74cdece55fe31eb87308c8c0cb99841085ad7 (diff)
sqlite: work around build breakage with !BR2_LARGEFILE
Should get fixed properly upstream, but this is good enough for 2009.11-rc1. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/database/sqlite/sqlite.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/database/sqlite/sqlite.mk b/package/database/sqlite/sqlite.mk
index 00e55598b..3375ca984 100644
--- a/package/database/sqlite/sqlite.mk
+++ b/package/database/sqlite/sqlite.mk
@@ -11,6 +11,15 @@ SQLITE_INSTALL_STAGING = YES
SQLITE_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
SQLITE_LIBTOOL_PATCH = NO
+ifneq ($(BR2_LARGEFILE),y)
+# the sqlite configure script fails to define SQLITE_DISABLE_LFS when
+# --disable-largefile is passed, breaking the build. Work around it by
+# simply adding it to CFLAGS for configure instead
+SQLITE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -DSQLITE_DISABLE_LFS"
+# changing CFLAGS doesn't work with config.cache
+SQLITE_USE_CONFIG_CACHE = NO
+endif
+
SQLITE_CONF_OPT = --enable-shared \
--enable-static \
--enable-tempstore=yes \