summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-06 19:58:45 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-06 20:18:41 +0200
commit2eb4b09529a891e07d09ddf36c483b28edcd19ae (patch)
treeff643ba547428eef8919eb0605df53a4af5eaa7c
parent6b939d40f6a29a43277566adc9d4312d49cb3abf (diff)
Add staging libraries directories to -L in external case
In order to solve issues of libtool trying to link target components against host libraries, it seems that specifying -L$(STAGING_DIR)/lib and -L$(STAGING_DIR)/usr/lib works. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/Makefile.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 0bec9a1c2..2ed7f423c 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -98,6 +98,7 @@ else ifeq ($(BR2_TOOLCHAIN_EXTERNAL),y)
TARGET_CFLAGS+=--sysroot $(STAGING_DIR)/
TARGET_CXXFLAGS=$(TARGET_CFLAGS)
TARGET_LDFLAGS=--sysroot $(STAGING_DIR)/
+TARGET_LDFLAGS+=-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib
endif
#########################################################################