summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-05-08 16:11:20 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-05-08 16:11:20 +0200
commitaf850ce10fc490036247a8c0dd92c79f18b2281a (patch)
treeac2e608f7d34096a9211e6e2d44b36384f38bbd4
parent395a70f72fbba38df396717f3c930e17d0f920dc (diff)
parentf6c18b97caeeae18ab2d8d19409183c6c905ec94 (diff)
Merge branch 'squashfs-fixes' of git://git.busybox.net/~tpetazzoni/git/buildroot
-rw-r--r--package/squashfs/squashfs.mk2
-rw-r--r--package/squashfs3/squashfs3-3.4-build-system-fix.patch (renamed from package/squashfs3/squashfs-3.4-build-system-fix.patch)15
-rw-r--r--package/squashfs3/squashfs3.mk2
3 files changed, 14 insertions, 5 deletions
diff --git a/package/squashfs/squashfs.mk b/package/squashfs/squashfs.mk
index ab05b06e5..1dccb0881 100644
--- a/package/squashfs/squashfs.mk
+++ b/package/squashfs/squashfs.mk
@@ -18,7 +18,7 @@ define SQUASHFS_INSTALL_TARGET_CMDS
endef
define HOST_SQUASHFS_BUILD_CMDS
- $(HOST_MAKE_ENV) $(MAKE) -C $(@D)/squashfs-tools/
+ $(HOST_MAKE_ENV) $(MAKE) CFLAGS="$(HOST_CFLAGS)" LDFLAGS="$(HOST_LDFLAGS)" -C $(@D)/squashfs-tools/
endef
define HOST_SQUASHFS_INSTALL_CMDS
diff --git a/package/squashfs3/squashfs-3.4-build-system-fix.patch b/package/squashfs3/squashfs3-3.4-build-system-fix.patch
index 5b86b008a..3c197eb1c 100644
--- a/package/squashfs3/squashfs-3.4-build-system-fix.patch
+++ b/package/squashfs3/squashfs3-3.4-build-system-fix.patch
@@ -9,9 +9,9 @@ Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Index: squashfs3.4/squashfs-tools/Makefile
===================================================================
---- squashfs3.4.orig/squashfs-tools/Makefile
-+++ squashfs3.4/squashfs-tools/Makefile
-@@ -2,12 +2,12 @@ INSTALL_DIR = /usr/local/bin
+--- squashfs3.4.orig/squashfs-tools/Makefile 2008-08-26 09:10:13.000000000 +0200
++++ squashfs3.4/squashfs-tools/Makefile 2010-05-06 21:09:28.000000000 +0200
+@@ -2,12 +2,12 @@
INCLUDEDIR = .
@@ -26,3 +26,12 @@ Index: squashfs3.4/squashfs-tools/Makefile
mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h
+@@ -16,7 +16,7 @@
+ sort.o: sort.c squashfs_fs.h global.h sort.h
+
+ unsquashfs: unsquashfs.o
+- $(CC) unsquashfs.o -lz -lpthread -lm -o $@
++ $(CC) $(LDFLAGS) unsquashfs.o -lz -lpthread -lm -o $@
+
+ unsquashfs.o: unsquashfs.c squashfs_fs.h read_fs.h global.h
+
diff --git a/package/squashfs3/squashfs3.mk b/package/squashfs3/squashfs3.mk
index 5504b1426..69aab1489 100644
--- a/package/squashfs3/squashfs3.mk
+++ b/package/squashfs3/squashfs3.mk
@@ -18,7 +18,7 @@ define SQUASHFS3_INSTALL_TARGET_CMDS
endef
define HOST_SQUASHFS3_BUILD_CMDS
- $(HOST_MAKE_ENV) $(MAKE) -C $(@D)/squashfs-tools/
+ $(HOST_MAKE_ENV) $(MAKE) CFLAGS="$(HOST_CFLAGS)" LDFLAGS="$(HOST_LDFLAGS)" -C $(@D)/squashfs-tools/
endef
define HOST_SQUASHFS3_INSTALL_CMDS