summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Ceresoli <luca@lucaceresoli.net>2010-05-06 00:16:59 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-05-06 23:27:58 +0200
commitea0695ff5edff392603a77b9299833fbb399e429 (patch)
treeae420798e8eae97e1b31c97d5c11093092bb883f
parent34d7dc874ad8536ba9e0f6f07e5bdfce5a82c51c (diff)
customize: fix copy paths
Closes #849, #1135 customize.mk used to copy files with a wrong command, resulting in one directory level in excess. For example, source/etc/myfile would have produced /etc/etc/myfile in the target filesystem instead of /etc/myfile. Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES4
-rw-r--r--package/customize/customize.mk2
2 files changed, 4 insertions, 2 deletions
diff --git a/CHANGES b/CHANGES
index 46939f0ea..10ca888e7 100644
--- a/CHANGES
+++ b/CHANGES
@@ -2,13 +2,15 @@
Fixes all over the tree.
- Updated/fixed packages: hal, mplayer, pciutils,
+ Updated/fixed packages: customize, hal, mplayer, pciutils,
xdriver_xf86-video-openchrome, usb_modeswitch, usbutils,
wpa_supplicant
Issues resolved (http://bugs.uclibc.org):
+ #849: "customize" package copies files to wrong place in target tree
#985: Bump usb_modeswitch package to 1.1.0
+ #1135: Package customize. Wrong copying
#1525: Package hal deletes a whole <target>/etc/rc.d directory
#1699: Fix usbutils dependencies and bump
#1705: Fix pciutils broken cross compiling
diff --git a/package/customize/customize.mk b/package/customize/customize.mk
index 780e42b00..d2b851872 100644
--- a/package/customize/customize.mk
+++ b/package/customize/customize.mk
@@ -11,7 +11,7 @@ $(BUILD_DIR)/.customize:
/bin/ls -d * > $(BUILD_DIR)/series || \
touch $(BUILD_DIR)/series )
for f in `cat $(BUILD_DIR)/series`; do \
- cp -af $(CUST_DIR)/$$f $(TARGET_DIR)/$$f; \
+ cp -af $(CUST_DIR)/$$f $(TARGET_DIR); \
done
rm -f $(BUILD_DIR)/series
touch $@