summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-29 11:14:00 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-29 22:18:56 +0200
commit0a67e7714706f260ae017f2b2807ddc64eab944a (patch)
tree7bbde6b57d6b2684670e2bc7c804b585becf6ce8
parentc19c6451413ed873eccf321e7f79cea1f78aa95d (diff)
speech-tools: fix build failure by using Debian version and patches
The upstream version of speech-tools does not build with GCC >= 4.3, mainly due to changes in how C++ headers are included. This is fixed in Debian, so let's use the Debian version and patches. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/multimedia/festival/speech-tools/speech-tools.mk17
1 files changed, 14 insertions, 3 deletions
diff --git a/package/multimedia/festival/speech-tools/speech-tools.mk b/package/multimedia/festival/speech-tools/speech-tools.mk
index 0aa44ccfa..66bd3080b 100644
--- a/package/multimedia/festival/speech-tools/speech-tools.mk
+++ b/package/multimedia/festival/speech-tools/speech-tools.mk
@@ -3,9 +3,11 @@
# speech-tools
#
#############################################################
-SPEECH_TOOLS_VERSION = 1.2.96-beta
-SPEECH_TOOLS_SOURCE = speech_tools-$(SPEECH_TOOLS_VERSION).tar.gz
-SPEECH_TOOLS_SITE = http://festvox.org/packed/festival/1.96
+
+SPEECH_TOOLS_VERSION = 1.2.96~beta
+SPEECH_TOOLS_SOURCE = speech-tools_$(SPEECH_TOOLS_VERSION).orig.tar.gz
+SPEECH_TOOLS_PATCH = speech-tools_$(SPEECH_TOOLS_VERSION)-6.diff.gz
+SPEECH_TOOLS_SITE = $(BR2_DEBIAN_MIRROR)/debian/pool/main/s/speech-tools/
SPEECH_TOOLS_AUTORECONF = NO
SPEECH_TOOLS_INSTALL_STAGING = NO
SPEECH_TOOLS_INSTALL_TARGET = YES
@@ -14,6 +16,15 @@ SPEECH_TOOLS_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) STRIP=$(TARGET_STRIP) in
SPEECH_TOOLS_CONF_OPT =
SPEECH_TOOLS_MAKE_OPT = CC="$(TARGET_CC)" CXX="$(TARGET_CXX)"
+define SPEECH_TOOLS_DEBIAN_PATCH_APPLY
+ # Use the order of the quilt patch series to apply the patches
+ for p in $$(cat $(@D)/debian/patches/series) ; do \
+ toolchain/patch-kernel.sh $(@D) $(@D)/debian/patches $$p; \
+ done
+endef
+
+SPEECH_TOOLS_POST_PATCH_HOOKS += SPEECH_TOOLS_DEBIAN_PATCH_APPLY
+
SPEECH_TOOLS_DEPENDENCIES = ncurses
$(eval $(call AUTOTARGETS,package/multimedia/festival,speech-tools))