summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-29 15:38:27 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-29 22:18:56 +0200
commitaf0a3d1cde4a65ee2487c5e042dc40fd346c5340 (patch)
tree7f39d62758fbb7a8190602b612c2e0495b1f29cd
parent9e06a8561665feb2c41e7a608b6849ac49ef0265 (diff)
u-boot: fix custom patch handling
When U-Boot is enabled and no custom patch directory has been set, then the current test: ifneq ($(strip $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),"") works. However, when U-Boot is not enabled, but still gets compiled because mkimage is needed to build the kernel, BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR is completely empty. It does not even have quotes. So the test in fact needs to be: ifneq ($(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),) Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--boot/u-boot/u-boot.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/boot/u-boot/u-boot.mk b/boot/u-boot/u-boot.mk
index 9eeea1d00..7b6b2ce63 100644
--- a/boot/u-boot/u-boot.mk
+++ b/boot/u-boot/u-boot.mk
@@ -77,7 +77,7 @@ $(U_BOOT_DIR)/.patched: $(U_BOOT_DIR)/.unpacked
toolchain/patch-kernel.sh $(U_BOOT_DIR) boot/u-boot \
u-boot-$(U_BOOT_VERSION)-\*.patch \
u-boot-$(U_BOOT_VERSION)-\*.patch.$(ARCH)
-ifneq ($(strip $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),"")
+ifneq ($(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),)
toolchain/patch-kernel.sh $(U_BOOT_DIR) $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR) u-boot-$(U_BOOT_VERSION)-\*.patch
endif
touch $@