summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-08-29 19:38:04 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-08-30 11:08:32 +0200
commit2ab8ec9e266cda26d6c782c75f666c39a033b7c7 (patch)
treed30d1ef2c6676f5064ff2d055276b3077d7a7cd6
parentd6d6ff6a9c6c48ca7871d5004fa77a4eb317efb5 (diff)
kismet: fix build when none of client, server or drone are selected
Random package configuration can trigger the selection of kismet, but neither of client, server or drone suboptions. In this case, the KISMET_TARGET_BINARIES variable is empty, leading to failure during the installation stage. At the same time, we remove the useless stripping of the installed binaries, since this is done globally by the Buildroot infrastructure. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--CHANGES7
-rw-r--r--package/kismet/kismet.mk7
2 files changed, 8 insertions, 6 deletions
diff --git a/CHANGES b/CHANGES
index 3cc717104..1cc9a387c 100644
--- a/CHANGES
+++ b/CHANGES
@@ -18,9 +18,10 @@
fs: old-style squashfs for big endian archs fixed.
Updated/fixed packages: busybox, gst-plugins-base,
- imagemagick, libgail, libglib2, libgtk2, lua, luafilesystem,
- lzo, ncurses, netcat, pango, php, pppd, proftpd, qt, samba,
- startup-notification, swfdec, sysvinit, util-linux
+ imagemagick, kismet, libgail, libglib2, libgtk2, lua,
+ luafilesystem, lzo, ncurses, netcat, pango, php, pppd,
+ proftpd, qt, samba, startup-notification, swfdec, sysvinit,
+ util-linux
Removed packages: stunnel
diff --git a/package/kismet/kismet.mk b/package/kismet/kismet.mk
index 1b61ddda3..6135c8873 100644
--- a/package/kismet/kismet.mk
+++ b/package/kismet/kismet.mk
@@ -33,18 +33,19 @@ $(eval $(call AUTOTARGETS,package,kismet))
$(KISMET_TARGET_INSTALL_TARGET):
$(call MESSAGE,"Installing")
+ifdef KISMET_TARGET_BINARIES
$(INSTALL) -m 755 $(addprefix $(KISMET_DIR)/, $(KISMET_TARGET_BINARIES)) $(TARGET_DIR)/usr/bin
+endif
ifdef KISMET_TARGET_CONFIGS
$(INSTALL) -m 644 $(addprefix $(KISMET_DIR)/conf/, $(KISMET_TARGET_CONFIGS)) $(TARGET_DIR)/etc
endif
-ifeq ($(BR2_ENABLE_DEBUG),)
- $(STRIPCMD) $(STRIP_STRIP_ALL) $(addprefix $(TARGET_DIR)/usr/bin/, $(KISMET_TARGET_BINARIES))
-endif
touch $@
$(KISMET_TARGET_UNINSTALL):
$(call MESSAGE,"Uninstalling")
+ifdef KISMET_TARGET_BINARIES
rm -f $(addprefix $(TARGET_DIR)/usr/bin/, $(KISMET_TARGET_BINARIES))
+endif
ifdef KISMET_TARGET_CONFIGS
rm -f $(addprefix $(TARGET_DIR)/etc/, $(KISMET_TARGET_CONFIGS))
endif