summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-08-22 08:01:55 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-08-24 15:05:19 +0200
commit8305f6ffbc391b25a24b25257089c1e0c99bd9aa (patch)
tree72cbbeb560d62899ebd323ab3e5a9df2a76a86b6
parente6c4ce6cef9f260226081f043b4f03dd4b0ad949 (diff)
lua: make sure that CFLAGS are passed
We were passing a custom MYCFLAGS value to Lua's Makefile, but because of $(TARGET_CONFIGURE_OPTS), we were also passing a CFLAGS variable, which was overriding Lua's internal CFLAGS variable. The result was that MYCFLAGS wasn't taken into account. Extracted from the patch proposed by François Perrad in bug #2353. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/lua/lua.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/lua/lua.mk b/package/lua/lua.mk
index d66be9fd3..598eea140 100644
--- a/package/lua/lua.mk
+++ b/package/lua/lua.mk
@@ -24,7 +24,9 @@ endif
define LUA_BUILD_CMDS
sed -i -e 's/-O2//' $(@D)/src/Makefile
sed -i -e 's/\/usr\/local/\/usr/' $(@D)/etc/lua.pc
- $(MAKE) $(TARGET_CONFIGURE_OPTS) MYCFLAGS="$(LUA_MYCFLAGS)" \
+ $(MAKE) \
+ CC="$(TARGET_CC)" RANLIB="$(TARGET_RANLIB)" \
+ MYCFLAGS="$(TARGET_CFLAGS) $(LUA_MYCFLAGS)" \
MYLIBS="$(LUA_MYLIBS)" AR="$(TARGET_CROSS)ar rcu" \
PKG_VERSION=$(LUA_VERSION) -C $(@D)/src all
endef