summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDarcy Watkins <dwatkins@tranzeo.com>2010-08-19 12:19:17 -0700
committerPeter Korsgaard <jacmet@sunsite.dk>2010-08-29 23:08:59 +0200
commitb6207627b4d20628ca0491377f17c5f3c91627d9 (patch)
treea82060d449bf4d54af76ee82b710d52861edd839
parent6c5193878189d9d199f3d88df52406a375f3e51e (diff)
pppd.mk installs radattr.so twice and omits radrealms.so
In pppd.mk the radattr.so plugin (for radiua) is installed twice (the second install overwriting the first) but the radrealms.so plugin is omitted from the install. This appears to be a copy-paste error. Below is patch that corrects this. signed-off by: Darcy Watkins <dwatkins@tranzeo.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES2
-rw-r--r--package/pppd/pppd.mk4
2 files changed, 3 insertions, 3 deletions
diff --git a/CHANGES b/CHANGES
index 317e9e69c..8550b6f71 100644
--- a/CHANGES
+++ b/CHANGES
@@ -18,7 +18,7 @@
fs: old-style squashfs for big endian archs fixed.
Updated/fixed packages: busybox, imagemagick, libglib2, lua,
- luafilesystem, lzo, netcat, php, proftpd, qt, samba,
+ luafilesystem, lzo, netcat, php, pppd, proftpd, qt, samba,
startup-notification, sysvinit, util-linux
Removed packages: stunnel
diff --git a/package/pppd/pppd.mk b/package/pppd/pppd.mk
index 9d081f21a..35fd451d7 100644
--- a/package/pppd/pppd.mk
+++ b/package/pppd/pppd.mk
@@ -55,8 +55,8 @@ $(PPPD_TARGET_INSTALL_TARGET):
$(TARGET_DIR)/usr/lib/pppd/$(PPPD_VERSION)/radattr.so
$(INSTALL) -D $(PPPD_DIR)/pppd/plugins/radius/radius.so \
$(TARGET_DIR)/usr/lib/pppd/$(PPPD_VERSION)/radius.so
- $(INSTALL) -D $(PPPD_DIR)/pppd/plugins/radius/radattr.so \
- $(TARGET_DIR)/usr/lib/pppd/$(PPPD_VERSION)/radattr.so
+ $(INSTALL) -D $(PPPD_DIR)/pppd/plugins/radius/radrealms.so \
+ $(TARGET_DIR)/usr/lib/pppd/$(PPPD_VERSION)/radrealms.so
for m in $(PPPD_MANPAGES); do \
$(INSTALL) -m 644 -D $(PPPD_DIR)/$$m/$$m.8 \
$(TARGET_DIR)/usr/share/man/man8/$$m.8; \