summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2010-11-02 16:35:11 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-05 00:01:58 +0100
commit666bef2d20a35507827284c874e23f43c3745f34 (patch)
treefa466a5c76c7eec56470fde195e086843af0cc6b
parentde642c9904b13914017af6f10db144d559d6bd0c (diff)
argp-standalone: new package
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES4
-rw-r--r--package/Config.in1
-rw-r--r--package/argp-standalone/Config.in6
-rw-r--r--package/argp-standalone/argp-standalone-throw-in-funcdef.patch79
-rw-r--r--package/argp-standalone/argp-standalone.mk21
5 files changed, 109 insertions, 2 deletions
diff --git a/CHANGES b/CHANGES
index 57511fdf4..019ce09aa 100644
--- a/CHANGES
+++ b/CHANGES
@@ -21,8 +21,8 @@
Alpha, Cris, IA64 and Sparc64 architecture support removed.
- New packages: gdk-pixbuf, gpsd, gst-ffmpeg, libmpeg2, librsvg,
- rrdtool, xz
+ New packages: argp-standalone, gdk-pixbuf, gpsd, gst-ffmpeg,
+ libmpeg2, librsvg, rrdtool, xz
Updated/fixed packages: acpid, alsa-lib, argus, at, autoconf,
automake, avahi, axel, beecrypt, berkeleydb, bind, bmon, boa,
diff --git a/package/Config.in b/package/Config.in
index fb415d70a..a86b6b347 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -311,6 +311,7 @@ source "package/libupnp/Config.in"
endmenu
menu "Other"
+source "package/argp-standalone/Config.in"
source "package/libatomic_ops/Config.in"
source "package/libcap/Config.in"
source "package/libdaemon/Config.in"
diff --git a/package/argp-standalone/Config.in b/package/argp-standalone/Config.in
new file mode 100644
index 000000000..5a0c05153
--- /dev/null
+++ b/package/argp-standalone/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_ARGP_STANDALONE
+ bool "argp-standalone"
+ help
+ Glibc hierarchical argument parsing standalone library.
+
+ http://www.lysator.liu.se/~nisse/misc/
diff --git a/package/argp-standalone/argp-standalone-throw-in-funcdef.patch b/package/argp-standalone/argp-standalone-throw-in-funcdef.patch
new file mode 100644
index 000000000..4a90751e1
--- /dev/null
+++ b/package/argp-standalone/argp-standalone-throw-in-funcdef.patch
@@ -0,0 +1,79 @@
+# --- T2-COPYRIGHT-NOTE-BEGIN ---
+# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
+#
+# T2 SDE: package/.../rng-tools/throw-in-funcdef.patch.argp-standalone
+# Copyright (C) 2006 The T2 SDE Project
+#
+# More information can be found in the files COPYING and README.
+#
+# This patch file is dual-licensed. It is available under the license the
+# patched project is licensed under, as long as it is an OpenSource license
+# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
+# of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or (at your option) any later
+# version.
+# --- T2-COPYRIGHT-NOTE-END ---
+
+
+No __THROW in function implementation.
+ --jsaw
+
+--- argp-standalone-1.4-test2/argp.h.orig 2006-01-06 02:29:59.000000000 +0100
++++ argp-standalone-1.4-test2/argp.h 2006-01-06 02:41:10.000000000 +0100
+@@ -560,17 +560,17 @@
+ # endif
+
+ # ifndef ARGP_EI
+-# define ARGP_EI extern __inline__
++# define ARGP_EI extern inline
+ # endif
+
+ ARGP_EI void
+-__argp_usage (__const struct argp_state *__state) __THROW
++__argp_usage (__const struct argp_state *__state)
+ {
+ __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
+ }
+
+ ARGP_EI int
+-__option_is_short (__const struct argp_option *__opt) __THROW
++__option_is_short (__const struct argp_option *__opt)
+ {
+ if (__opt->flags & OPTION_DOC)
+ return 0;
+@@ -582,7 +582,7 @@
+ }
+
+ ARGP_EI int
+-__option_is_end (__const struct argp_option *__opt) __THROW
++__option_is_end (__const struct argp_option *__opt)
+ {
+ return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
+ }
+--- argp-standalone-1.4-test2/argp-parse.c.orig 2006-01-06 02:47:48.000000000 +0100
++++ argp-standalone-1.4-test2/argp-parse.c 2006-01-06 02:48:16.000000000 +0100
+@@ -1290,13 +1290,13 @@
+ /* Defined here, in case a user is not inlining the definitions in
+ * argp.h */
+ void
+-__argp_usage (__const struct argp_state *__state) __THROW
++__argp_usage (__const struct argp_state *__state)
+ {
+ __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
+ }
+
+ int
+-__option_is_short (__const struct argp_option *__opt) __THROW
++__option_is_short (__const struct argp_option *__opt)
+ {
+ if (__opt->flags & OPTION_DOC)
+ return 0;
+@@ -1310,7 +1310,7 @@
+ }
+
+ int
+-__option_is_end (__const struct argp_option *__opt) __THROW
++__option_is_end (__const struct argp_option *__opt)
+ {
+ return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
+ }
diff --git a/package/argp-standalone/argp-standalone.mk b/package/argp-standalone/argp-standalone.mk
new file mode 100644
index 000000000..f48d0e699
--- /dev/null
+++ b/package/argp-standalone/argp-standalone.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# argp-standalone
+#
+#############################################################
+
+ARGP_STANDALONE_VERSION = 1.3
+ARGP_STANDALONE_SITE = http://www.lysator.liu.se/~nisse/archive
+ARGP_STANDALONE_INSTALL_STAGING = YES
+
+define ARGP_STANDALONE_INSTALL_STAGING_CMDS
+ $(INSTALL) -D $(@D)/libargp.a $(STAGING_DIR)/usr/lib/libargp.a
+ $(INSTALL) -D $(@D)/argp.h $(STAGING_DIR)/usr/include/argp.h
+endef
+
+define ARGP_STANDALONE_INSTALL_TARGET_CMDS
+ $(INSTALL) -D $(@D)/libargp.a $(TARGET_DIR)/usr/lib/libargp.a
+ $(INSTALL) -D $(@D)/argp.h $(TARGET_DIR)/usr/include/argp.h
+endef
+
+$(eval $(call AUTOTARGETS,package,argp-standalone))