summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-05-17 10:00:01 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-05-17 10:00:01 +0200
commitce1ae872aa72547bb291cc9e70adfe1b065cd2a8 (patch)
tree9ecc971f810385b7d3826b148765ac48eb24e326
parentf890debb30c0ce920bc44e7d74f1d5d4280d4625 (diff)
Makefile.autotools.in: default to same <pkg>_MAKE setting for host and target
Similar to how it is done for _SOURCE, _PATCH, _SITE and _SUBDIR. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/Makefile.autotools.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 61fcfcfa2..917600ca0 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -57,9 +57,16 @@ ifndef $(2)_LIBTOOL_PATCH
endif
endif
+ifndef $(2)_MAKE
+ ifdef $(3)_MAKE
+ $(2)_MAKE = $($(3)_MAKE)
+ else
+ $(2)_MAKE ?= $(MAKE)
+ endif
+endif
+
$(2)_CONF_ENV ?=
$(2)_CONF_OPT ?=
-$(2)_MAKE ?= $(MAKE)
$(2)_MAKE_ENV ?=
$(2)_MAKE_OPT ?=
$(2)_AUTORECONF ?= NO