summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-08-12 09:45:50 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-08-12 09:45:50 +0200
commit71f279f9a2bd3f086f3d31fa5a669d3f638bee99 (patch)
treedb4ef6614a7694efe0d6d61053630e59f5e5224c
parentac7d781f7c6653d08b9044bda786db480a5ed673 (diff)
util-linux: fix install when locales are enabled
util-linux uses mkinstalldirs to install .po files when locales are enabled, but the definition of MKINSTALLDIRS comes from a tweaked nls.m4 (based on the one from gettext). When we autoreconf the package, we end up using the system (staging) version of nls.m4, so MKINSTALLDIRS doesn't get defined. Fix it by passing a definition of MKINSTALLDIRS to make during the install steps. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/util-linux/util-linux.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index dd6ee5c69..9d2f9be3b 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -68,3 +68,8 @@ UTIL_LINUX_CONF_OPT += \
$(if $(BR2_PACKAGE_UTIL_LINUX_WRITE),--enable-write)
$(eval $(call AUTOTARGETS,package,util-linux))
+
+# MKINSTALLDIRS comes from tweaked m4/nls.m4, but autoreconf uses staging
+# one, so it disappears
+UTIL_LINUX_INSTALL_STAGING_OPT += MKINSTALLDIRS=$(@D)/config/mkinstalldirs
+UTIL_LINUX_INSTALL_TARGET_OPT += MKINSTALLDIRS=$(@D)/config/mkinstalldirs