summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-22 09:22:07 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-22 09:22:07 +0000
commitaa81a0650884a0563e6dcb41dc15a5635a28481d (patch)
treead8e2788b9b644366128ded4f25bbe9e7e96b582
parent26b4c3782b0d6b75e1dc4985a5714cf68566b0a8 (diff)
- improve the way host prerequisites for "dependencies" are established
-rw-r--r--target/linux/Makefile.in10
-rw-r--r--toolchain/dependencies/dependencies.mk10
-rw-r--r--toolchain/kernel-headers/Config.in13
3 files changed, 8 insertions, 25 deletions
diff --git a/target/linux/Makefile.in b/target/linux/Makefile.in
index 2b9421428..c65e241cb 100644
--- a/target/linux/Makefile.in
+++ b/target/linux/Makefile.in
@@ -59,14 +59,6 @@ ifndef LINUX26_KERNEL
LINUX26_KERNEL=$(BINARIES_DIR)/linux-kernel-$(LINUX26_VERSION)-$(KERNEL_ARCH)
endif
-ifeq ($(BR2_KERNEL_HEADERS_LZMA),y)
-ifeq ($(BR2_KERNEL_HEADERS_LZMA_INSTALL),y)
-DEPEND_ON_HOST_LZMA:=lzma-host-install
-else
-DEPEND_ON_HOST_LZMA:=lzma-host
-endif
-endif
-
# Version of Linux AFTER patches
LINUX26_DIR=$(BUILD_DIR)/linux-$(LINUX26_VERSION)
@@ -165,7 +157,7 @@ linux26-menuconfig: $(LINUX26_DIR)/.patched host-sed
$(MAKE) $(LINUX26_MAKE_FLAGS) -C $(LINUX26_DIR) menuconfig
-[ -f $(LINUX26_DIR)/.config ] && touch $(LINUX26_DIR)/.configured
-linux26: $(DEPEND_ON_HOST_LZMA) $(INITRAMFS_TARGET) $(LINUX26_KERNEL)
+linux26: $(INITRAMFS_TARGET) $(LINUX26_KERNEL)
$(LINUX26_DIR)/.modules_installed: $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/modules.dep
touch $@
diff --git a/toolchain/dependencies/dependencies.mk b/toolchain/dependencies/dependencies.mk
index 4af03b8f8..d50042462 100644
--- a/toolchain/dependencies/dependencies.mk
+++ b/toolchain/dependencies/dependencies.mk
@@ -5,11 +5,15 @@
#
######################################################################
+DEPENDENCIES_HOST_PREREQ:=
ifeq ($(BR2_STRIP_sstrip),y)
-# XXX: this is a little bit ugly, yep.
-MAYBE_SSTRIP_HOST:=sstrip_host
+DEPENDENCIES_HOST_PREREQ+=sstrip_host
endif
-dependencies: host-sed host-lzma $(MAYBE_SSTRIP_HOST)
+ifneq ($(findstring y,$(BR2_KERNEL_HEADERS_LZMA)),)
+DEPENDENCIES_HOST_PREREQ+=host-lzma
+endif
+
+dependencies: host-sed $(DEPENDENCIES_HOST_PREREQ)
@HOSTCC="$(firstword $(HOSTCC))" MAKE="$(MAKE)" \
HOST_SED_DIR="$(HOST_SED_DIR)" \
$(TOPDIR)/toolchain/dependencies/dependencies.sh
diff --git a/toolchain/kernel-headers/Config.in b/toolchain/kernel-headers/Config.in
index 05587b809..808433a7a 100644
--- a/toolchain/kernel-headers/Config.in
+++ b/toolchain/kernel-headers/Config.in
@@ -74,19 +74,6 @@ config BR2_KERNEL_HEADERS_LZMA
initramfs filesystems. This requires the lzma
program in your development environment.
-config BR2_KERNEL_HEADERS_LZMA_INSTALL
- bool "Install lzma in /usr/local/bin (Requires system password) for sudo"
- depends on BR2_KERNEL_HEADERS_2_6_21 || BR2_KERNEL_HEADERS_2_6_22
- depends on BR2_KERNEL_HEADERS_LZMA
- default n
- help
- Install the lzma package in the /usr/local/bin directory
- so it is available for future builds. This requires sudo.
- If you do not know the system password you should not set
- this option. If you do not have lzma installed the only way
- to complete the linux build, ifl you apply the lzma patches
- is to have '$(STAGING_DIR)/usr/bin' in your path.
-
config BR2_KERNEL_HEADERS_PATCH_DIR
bool "Add additional headers from $(KERNEL_HEADERS_PATCH_DIR)"
default n