diff options
author | Thomas Petazzoni <thomas.petazzoni@free-electrons.com> | 2009-08-04 21:42:48 +0200 |
---|---|---|
committer | Thomas Petazzoni <thomas.petazzoni@free-electrons.com> | 2009-08-04 21:45:04 +0200 |
commit | 6ce736a58c8973ceba56bc95f11118b7c1351f11 (patch) | |
tree | e91a898eaa8d1c1b0dfdb2ff9177aaa763913c7d | |
parent | 5b72dda69f72e1953dfc7987dd1b418e1afe79a4 (diff) |
sed: fix compilation with external toolchains
Since CC is already passed in TARGET_CONFIGURE_OPTS at ./configure
time, there's no point in overriding it with a wrong value at
compilation time. This breaks external toolchain builds since
CC=$(TARGET_CC) is wrong because it excludes the mandatory --sysroot
option.
Fixes bug #525
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r-- | CHANGES | 1 | ||||
-rw-r--r-- | package/sed/sed.mk | 2 |
2 files changed, 2 insertions, 1 deletions
@@ -77,6 +77,7 @@ #497: OpenSSL RSA key generation hangs on x86_64 #509: Bump sqlite package to 3.6.16 #523: pciutils broken with external toolchain + #525: sed broken with external toolchain #533: Update gamin to 0.1.10 to fix compilation 2009.05, Released June 1st, 2009: diff --git a/package/sed/sed.mk b/package/sed/sed.mk index 9caefed49..07f4b32c6 100644 --- a/package/sed/sed.mk +++ b/package/sed/sed.mk @@ -135,7 +135,7 @@ $(SED_DIR2)/.configured: $(SED_DIR2)/.unpacked touch $@ $(SED_DIR2)/$(SED_BINARY): $(SED_DIR2)/.configured - $(MAKE) CC=$(TARGET_CC) -C $(SED_DIR2) + $(MAKE) -C $(SED_DIR2) # This stuff is needed to work around GNU make deficiencies sed-target_binary: $(SED_DIR2)/$(SED_BINARY) |