diff options
author | Mark Wickham <markw@digi.com> | 2011-02-04 19:45:46 +0100 |
---|---|---|
committer | Peter Korsgaard <jacmet@sunsite.dk> | 2011-02-04 19:46:45 +0100 |
commit | c18c1d667afb3cdc1e1cd177a4b2d5ad77203731 (patch) | |
tree | 7120fd92feac8374d8e625ce8e2bf68f6b265298 | |
parent | 694301dc5acd5b78d7baae69d622b3f07eb4ef4e (diff) |
python: fix modules_lib_dirs typo in patch-2.7-005-stagng-headers-libs.patch
Closes #3169
Typo in modules_lib_dirs section of patch specified modules_include_dirs
instead of modules_lib_dirs. This matters if PYTHON_MODULES_LIB
is not passed into the script.
Signed-off-by: Mark Wickham <markw@digi.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r-- | CHANGES | 1 | ||||
-rw-r--r-- | package/python/python-2.7-005-staging-headers-libs.patch | 2 |
2 files changed, 2 insertions, 1 deletions
@@ -97,6 +97,7 @@ #3103: make external-deps wants to download gcc-.tar.bz2 when... #3109: abnormal `make busybox-menuconfig` #3115: How about board specific makefiles? + #3169: python patch has typo, aborts build in scenario #3181: dhcp.mk copies S80dhcp-server to etc/init.d, not etc/init.d/ 2010.11, Released November 30th, 2010: diff --git a/package/python/python-2.7-005-staging-headers-libs.patch b/package/python/python-2.7-005-staging-headers-libs.patch index ab3d88e73..170e81970 100644 --- a/package/python/python-2.7-005-staging-headers-libs.patch +++ b/package/python/python-2.7-005-staging-headers-libs.patch @@ -27,7 +27,7 @@ Index: Python-2.7.1/setup.py + try: + modules_lib_dirs = os.environ["PYTHON_MODULES_LIB"].split() + except KeyError: -+ modules_include_dirs = ['/usr/lib'] ++ modules_lib_dirs = ['/usr/lib'] + for dir in modules_include_dirs: + add_dir_to_list(self.compiler.include_dirs, dir) + for dir in modules_lib_dirs: |