diff options
author | Thomas Petazzoni <thomas.petazzoni@free-electrons.com> | 2009-08-02 00:34:47 +0200 |
---|---|---|
committer | Thomas Petazzoni <thomas.petazzoni@free-electrons.com> | 2009-08-02 00:36:47 +0200 |
commit | dcb752b1654d4186d02bbaa9db3b865ac03785cd (patch) | |
tree | 2fe760f8f0304ab7aa7f9ea29759362710147f05 | |
parent | e15c0d07e15e94e800bd9a0cf3c24f45aeacd89c (diff) |
pciutils: fix build with external toolchains
Buildroot Makefile to compile pciutils wasn't passing TARGET_LDFLAGS
to pciutils build system. Therefore, at link time, the pciutils build
system was not taking into account the important --sysroot option,
which was breaking the link with external toolchains.
Fixes bug #523.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r-- | CHANGES | 1 | ||||
-rw-r--r-- | package/pciutils/pciutils.mk | 2 |
2 files changed, 2 insertions, 1 deletions
@@ -50,6 +50,7 @@ #495: Bump bind package to 9.5.1-P3 (security) #497: OpenSSL RSA key generation hangs on x86_64 #509: Bump sqlite package to 3.6.16 + #527: pciutils broken with external toolchain 2009.05, Released June 1st, 2009: diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk index 0d8155f40..976afbf17 100644 --- a/package/pciutils/pciutils.mk +++ b/package/pciutils/pciutils.mk @@ -41,7 +41,7 @@ $(PCIUTILS_DIR)/.unpacked: $(DL_DIR)/$(PCIUTILS_SOURCE) $(DL_DIR)/$(PCIIDS_SOURC touch $@ $(PCIUTILS_DIR)/.compiled: $(PCIUTILS_DIR)/.unpacked - $(MAKE1) CC="$(TARGET_CC)" OPT="$(TARGET_CFLAGS)" RANLIB=$(TARGET_RANLIB) AR=$(TARGET_AR) -C $(PCIUTILS_DIR) \ + $(MAKE1) CC="$(TARGET_CC)" OPT="$(TARGET_CFLAGS)" LDFLAGS="$(TARGET_LDFLAGS)" RANLIB=$(TARGET_RANLIB) AR=$(TARGET_AR) -C $(PCIUTILS_DIR) \ SHAREDIR="/usr/share/misc" \ ZLIB=$(PCIUTILS_HAVE_ZLIB) \ HOST=$(KERNEL_ARCH)-linux \ |