summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-02-26 08:24:23 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-02-26 08:24:23 +0100
commit261cb20a08e9dddb047381aa059c7f9e351e6109 (patch)
tree41ad14a6cf8480fbb8e557da923b25203967628e
parent5ddfc1270324eb4abae18dfa41cbc8269132c4e0 (diff)
Makefile.cmake.in: fix automatic host deps calculation
We need similar handling as in autotools because of the host-cmake addition. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/Makefile.cmake.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/Makefile.cmake.in b/package/Makefile.cmake.in
index 38e459b80..4a4ad6e2d 100644
--- a/package/Makefile.cmake.in
+++ b/package/Makefile.cmake.in
@@ -96,6 +96,10 @@ endef
endif
endif
+# This must be repeated from GENTARGETS_INNER, otherwise we only get
+# host-cmake in _DEPENDENCIES because of the following line
+$(2)_DEPENDENCIES ?= $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
+
$(2)_DEPENDENCIES += host-cmake
#