summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-08 16:00:05 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-08 16:00:05 +0000
commit381359328f3b28326ce1f1423377c4d3faf3eafa (patch)
treec4036b8f91413a3f826a7cbc41eddf469b883a80
parentb2e89e7d8c10f9203b7d57402c4db7252e92a8c7 (diff)
update so that it actually works ;)
-rw-r--r--make/pciutils.mk38
-rw-r--r--sources/pciutils.patch29
2 files changed, 39 insertions, 28 deletions
diff --git a/make/pciutils.mk b/make/pciutils.mk
index f8608d8fc..0b51aa8ba 100644
--- a/make/pciutils.mk
+++ b/make/pciutils.mk
@@ -3,9 +3,10 @@
# pciutils
#
#############################################################
-PCIUTILS_SOURCE:=pciutils-2.1.10.tar.gz
+PCIUTILS_VER:=2.1.11
+PCIUTILS_SOURCE:=pciutils-$(PCIUTILS_VER).tar.gz
PCIUTILS_SITE:=ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
-PCIUTILS_DIR:=$(BUILD_DIR)/pciutils-2.1.10
+PCIUTILS_DIR:=$(BUILD_DIR)/pciutils-$(PCIUTILS_VER)
PCIUTILS_CAT:=zcat
# Yet more targets...
@@ -24,39 +25,20 @@ pciutils-source: $(DL_DIR)/$(PCIUTILS_SOURCE) $(DL_DIR)/$(PCIIDS_SOURCE)
$(PCIUTILS_DIR)/.unpacked: $(DL_DIR)/$(PCIUTILS_SOURCE) $(DL_DIR)/$(PCIIDS_SOURCE)
$(PCIUTILS_CAT) $(DL_DIR)/$(PCIUTILS_SOURCE) | tar -C $(BUILD_DIR) -xvf -
$(PCIIDS_CAT) $(DL_DIR)/$(PCIIDS_SOURCE) > $(PCIUTILS_DIR)/pci.id
+ $(SOURCE_DIR)/patch-kernel.sh $(PCIUTILS_DIR) $(SOURCE_DIR) pciutils*.patch
touch $(PCIUTILS_DIR)/.unpacked
-$(PCIUTILS_DIR)/.configured: $(PCIUTILS_DIR)/.unpacked
- (cd $(PCIUTILS_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- $(DISABLE_NLS) \
- );
- touch $(PCIUTILS_DIR)/.configured
+$(PCIUTILS_DIR)/.compiled: $(PCIUTILS_DIR)/.unpacked
+ $(MAKE) CC=$(TARGET_CC) OPT=$(TARGET_CFLAGS) -C $(PCIUTILS_DIR)
+ touch $(PCIUTILS_DIR)/.compiled
-$(PCIUTILS_DIR)/lspci: $(PCIUTILS_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) -C $(PCIUTILS_DIR)
-
-$(TARGET_DIR)/sbin/lspci: $(PCIUTILS_DIR)/lspci
+$(TARGET_DIR)/sbin/lspci: $(PCIUTILS_DIR)/.compiled
install -c $(PCIUTILS_DIR)/lspci $(TARGET_DIR)/sbin/lspci
-$(TARGET_DIR)/sbin/setpci: $(PCIUTILS_DIR)/setpci
+$(TARGET_DIR)/sbin/setpci: $(PCIUTILS_DIR)/.compiled
install -c $(PCIUTILS_DIR)/setpci $(TARGET_DIR)/sbin/setpci
-$(TARGET_DIR)/usr/share/misc/pci.ids: $(PCIUTILS_DIR)/.dist
+$(TARGET_DIR)/usr/share/misc/pci.ids: $(PCIUTILS_DIR)/.compiled
install -Dc $(PCIUTILS_DIR)/pci.ids $(TARGET_DIR)/usr/share/misc/pci.ids
diff --git a/sources/pciutils.patch b/sources/pciutils.patch
new file mode 100644
index 000000000..7718b253a
--- /dev/null
+++ b/sources/pciutils.patch
@@ -0,0 +1,29 @@
+diff -ur pciutils-2.1.11.orig/lib/configure pciutils-2.1.11/lib/configure
+--- pciutils-2.1.11.orig/lib/configure 2004-10-08 11:56:42.876316816 -0400
++++ pciutils-2.1.11/lib/configure 2004-10-08 11:57:04.965958680 -0400
+@@ -25,7 +25,6 @@
+ echo " $sys/$cpu $rel"
+
+ c=config.h
+-echo >$c "#define ARCH_`echo $cpu | tr 'a-z' 'A-Z'`"
+ echo >>$c "#define OS_`echo $sys | tr 'a-z' 'A-Z'`"
+
+ echo_n "Looking for access methods..."
+@@ -40,17 +39,6 @@
+ ok=1
+ ;;
+ esac
+- case $cpu in
+- i386) echo_n " i386-ports"
+- echo >>$c '#define HAVE_PM_INTEL_CONF'
+- ok=1
+- ;;
+- alpha|ia64) echo >>$c '#define HAVE_64BIT_ADDRESS'
+- ;;
+- sparc|sparc64) echo >>$c '#define HAVE_64BIT_ADDRESS'
+- echo >>$c '#define HAVE_LONG_ADDRESS'
+- ;;
+- esac
+ ;;
+ FreeBSD)
+ echo_n " fbsd-device"