summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Golubovsky <golubovsky@gmail.com>2012-05-05 16:05:18 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-06 09:51:00 +0200
commitadebe9df0f42a929441d40e84f30e546f2852d68 (patch)
tree736e67dae74f1694e6d455a4503021865b464236
parent0b93a8ceadf13a98cb4ac5dada52dcd92307edf6 (diff)
package: add read-edid
[Peter: fixup whitespace] Signed-off-by: Dmitry <golubovsky@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/Config.in1
-rw-r--r--package/read-edid/Config.in14
-rw-r--r--package/read-edid/read-edid.mk19
3 files changed, 34 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 6caca9da4..94d0fb47f 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -211,6 +211,7 @@ source "package/openocd/Config.in"
source "package/parted/Config.in"
source "package/pciutils/Config.in"
source "package/picocom/Config.in"
+source "package/read-edid/Config.in"
source "package/rng-tools/Config.in"
source "package/sane-backends/Config.in"
source "package/sdparm/Config.in"
diff --git a/package/read-edid/Config.in b/package/read-edid/Config.in
new file mode 100644
index 000000000..bdcb7a7d2
--- /dev/null
+++ b/package/read-edid/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_READ_EDID
+ bool "read-edid"
+ depends on BR2_i386
+ help
+ Read-edid is a pair of tools for reading the EDID from a
+ monitor. It should work with most monitors made since 1996
+ (except for newer ones with 256-byte EDID's - WiP), assuming
+ the video card supports the standard read commands (most
+ do). Read-edid is a set of two tools - get-edid, which gets
+ the raw edid information from the monitor, and parse-edid,
+ which turns the raw binary information into an
+ XF86Config-compatible monitor section.
+
+ http://polypux.org/projects/read-edid/
diff --git a/package/read-edid/read-edid.mk b/package/read-edid/read-edid.mk
new file mode 100644
index 000000000..b568d5b8b
--- /dev/null
+++ b/package/read-edid/read-edid.mk
@@ -0,0 +1,19 @@
+############################################
+#
+# read-edid
+#
+############################################
+
+READ_EDID_VERSION = 1.4.2
+READ_EDID_SITE = http://www.polypux.org/projects/read-edid/
+
+define READ_EDID_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define READ_EDID_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/get-edid $(TARGET_DIR)/sbin/get-edid
+ $(INSTALL) -D -m 0755 $(@D)/parse-edid $(TARGET_DIR)/sbin/parse-edid
+endef
+
+$(eval $(call AUTOTARGETS))