summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-05-07 04:04:34 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-05-07 04:04:34 +0000
commit58ef6b3ca7e0c195e7ef0d9523661aa333cf88b6 (patch)
treee9d51c28c2360605bba209b6bc45f7d46ede0d60
parentdbf0e5eef61a37f427ba1a3aa11db5c880486933 (diff)
If any of the netkit packages were selected, we disable their counterparts in Busybox and warn the user.
-rw-r--r--package/busybox/busybox.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index c939b5f1f..16e3ee835 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -78,6 +78,16 @@ ifeq ($(BR2_PACKAGE_BUSYBOX_SKELETON),y)
# force mdev on
$(SED) "s/^.*CONFIG_MDEV.*/CONFIG_MDEV=y/" $(BUSYBOX_DIR)/.config
endif
+ifeq ($(BR2_PACKAGE_NETKITBASE),y)
+ # disable usage of inetd if netkit-base package is selected
+ $(SED) "s/^.*CONFIG_INETD.*/CONFIG_INETD=n/;" $(BUSYBOX_DIR)/.config
+ @echo "WARNING!! CONFIG_INETD option disabled!"
+endif
+ifeq ($(BR2_PACKAGE_NETKITTELNET),y)
+ # disable usage of telnetd if netkit-telnetd package is selected
+ $(SED) "s/^.*CONFIG_TELNETD.*/CONFIG_TELNETD=n/;" $(BUSYBOX_DIR)/.config
+ @echo "WARNING!! CONFIG_TELNETD option disabled!"
+endif
yes "" | $(MAKE) CC=$(TARGET_CC) CROSS_COMPILE="$(TARGET_CROSS)" \
CROSS="$(TARGET_CROSS)" -C $(BUSYBOX_DIR) oldconfig
touch $@