diff options
author | Thomas Petazzoni <thomas.petazzoni@free-electrons.com> | 2009-07-31 10:31:39 +0200 |
---|---|---|
committer | Thomas Petazzoni <thomas.petazzoni@free-electrons.com> | 2009-09-16 20:33:31 +0200 |
commit | 3b2a803d2842e45a28b58afde6835dc40edb4c52 (patch) | |
tree | 8523e795259caa6b039f4b39ff332e0b632a53ad /Makefile | |
parent | fd3800c1979d9d76e2c4f802c2d279290c102218 (diff) |
Rename the output directories
In the output directory, we now have
- build/ where all the packages are built
- images/ where the final kernel and rootfs images are stored
- staging/ the staging directory (containing the development files
and libraries compiled for the target)
- target/ which contains the target root filesystem
- host/ which contains all the host programs
- stamps/ which contains the stamps files
Therefore, the build_ARCH and toolchain_build_ARCH have been
removed. People willing to use the same Buildroot sources to compile
for different architectures are invited to use the O= command line
option for out-of-tree compilation.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 10 |
1 files changed, 5 insertions, 5 deletions
@@ -235,20 +235,20 @@ ifeq ($(DL_DIR),) DL_DIR:=$(BASE_DIR)/dl endif -BUILD_DIR:=$(BASE_DIR)/build_$(ARCH)$(ARCH_FPU_SUFFIX) +BUILD_DIR:=$(BASE_DIR)/build GNU_TARGET_SUFFIX:=-$(call qstrip,$(BR2_GNU_TARGET_SUFFIX)) STAGING_DIR:=$(call qstrip,$(BR2_STAGING_DIR)) # packages compiled for the host goes here -HOST_DIR:=$(BUILD_DIR)/host_dir +HOST_DIR:=$(BASE_DIR)/host # stamp (dependency) files go here -STAMP_DIR:=$(BUILD_DIR)/stamps +STAMP_DIR:=$(BASE_DIR)/stamps -BINARIES_DIR:=$(BASE_DIR)/binaries/ -TARGET_DIR:=$(BUILD_DIR)/target_dir +BINARIES_DIR:=$(BASE_DIR)/images +TARGET_DIR:=$(BASE_DIR)/target # define values for prepatched source trees for toolchains VENDOR_SITE:=$(call qstrip,$(BR2_VENDOR_SITE)) |