summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-27 21:24:15 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-27 21:24:15 +0000
commit57310ec6050e73b88ba1cc19c04d8ce030f12f88 (patch)
tree6b90a1609246caa39e4845ad3f2697b851376349 /Makefile
parent1cf7a4c11759885143e76faaf5f9cff13fa95e72 (diff)
- for various reasons i will need an explicit ordering of the toolchain includes
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index a7d7f04d2..23107a189 100644
--- a/Makefile
+++ b/Makefile
@@ -202,7 +202,18 @@ include project/*.mk
# in the .config file.
ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
# avoid pulling in external toolchain which is broken for toplvl parallel builds
-include $(filter-out $(wildcard toolchain/external-toolchain/*),$(wildcard toolchain/*/*.mk))
+# Explicit ordering:
+include toolchain/dependencies/dependencies.mk
+include toolchain/binutils/binutils.mk
+include toolchain/ccache/ccache.mk
+include toolchain/elf2flt/elf2flt.mk
+include toolchain/gcc/gcc-uclibc-3.x.mk
+include toolchain/gcc/gcc-uclibc-4.x.mk
+include toolchain/gdb/gdb.mk
+include toolchain/kernel-headers/kernel-headers.mk
+include toolchain/mklibs/mklibs.mk
+include toolchain/sstrip/sstrip.mk
+include toolchain/uClibc/uclibc.mk
else
include toolchain/*/*.mk
endif