diff options
author | Wade Berrier <wberrier@gmail.com> | 2009-04-28 17:33:44 +0000 |
---|---|---|
committer | Wade Berrier <wberrier@gmail.com> | 2009-04-28 17:33:44 +0000 |
commit | 027aa1d2ec07402d9aa1df3825207f120acae497 (patch) | |
tree | 573a8a12cec31e7842b735762c31ff7ba0008516 /Makefile | |
parent | ff7e08083bee77f0078629aeb0904304a0850889 (diff) |
Older versions of 'find' don't have the '-delete' option
Use find's '-print0' and 'xargs -0' as an equivalent alternative.
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 8 |
1 files changed, 4 insertions, 4 deletions
@@ -334,8 +334,8 @@ $(PROJECT_BUILD_DIR)/.root: fi; \ touch $(STAGING_DIR)/.fakeroot.00000; \ fi - -find $(TARGET_DIR) -type d -name CVS -o -name .svn | xargs rm -rf - -find $(TARGET_DIR) -type f -name .empty | xargs rm -rf + -find $(TARGET_DIR) -type d -name CVS -o -name .svn -print0 | xargs -0 rm -rf + -find $(TARGET_DIR) -type f -name .empty -print0 | xargs -0 rm -rf touch $@ $(TARGET_DIR): $(PROJECT_BUILD_DIR)/.root @@ -348,8 +348,8 @@ ifeq ($(BR2_HAVE_DEVFILES),y) ( scripts/copy.sh $(STAGING_DIR) $(TARGET_DIR) ) else rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/lib/pkgconfig - find $(TARGET_DIR)/lib \( -name '*.a' -o -name '*.la' \) -delete - find $(TARGET_DIR)/usr/lib \( -name '*.a' -o -name '*.la' \) -delete + find $(TARGET_DIR)/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f + find $(TARGET_DIR)/usr/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f endif ifneq ($(BR2_HAVE_MANPAGES),y) rm -rf $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/man |