summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-11-04 12:50:38 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-11-04 12:50:38 +0000
commitd1a7ffe8f91437c31b864646bb1dbcb4573b8ee1 (patch)
tree32025d1a1915d3dc91e543069766ff86c6509912 /Makefile
parenta6db1e165d807310af46f99c3542866d88e06aa3 (diff)
Makefile: glib-genmarshal: use BR2_STAGING_DIR instead of hardcoded staging_dir
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f5d196712..5231bb6fa 100644
--- a/Makefile
+++ b/Makefile
@@ -123,7 +123,7 @@ HOSTLD:=$(shell $(CONFIG_SHELL) -c "which $(HOSTLD)" || type -p $(HOSTLD) || ech
HOSTLN:=$(shell $(CONFIG_SHELL) -c "which $(HOSTLN)" || type -p $(HOSTLN) || echo ln)
HOSTNM:=$(shell $(CONFIG_SHELL) -c "which $(HOSTNM)" || type -p $(HOSTNM) || echo nm)
# ignore version in staging_dir
-HOST_GLIB_BIN:=`dirname $(shell $(CONFIG_SHELL) -c "(which -a glib-genmarshal; echo /usr/bin/glib-genmarshal)|grep -v staging_dir|head -n 1")`
+HOST_GLIB_BIN:=`dirname $(shell $(CONFIG_SHELL) -c "(which -a glib-genmarshal; echo /usr/bin/glib-genmarshal)|grep -v $(BR2_STAGING_DIR)|head -n 1")`
HOST_GLIB:=$(shell $(CONFIG_SHELL) -c "dirname $(HOST_GLIB_BIN)" || echo /usr)