diff options
author | Gustavo Zacarias <gustavo@zacarias.com.ar> | 2010-11-30 12:19:59 -0300 |
---|---|---|
committer | Peter Korsgaard <jacmet@sunsite.dk> | 2010-11-30 16:28:41 +0100 |
commit | 0dc940cdeeaa1fae3510ff8a1b581f4ecf27b5c4 (patch) | |
tree | b696e633fb648282b47b96c52899e7a6e21cf865 /Makefile | |
parent | 87683d7e9c524800f8d90ecfbdc44818430e684f (diff) |
Makefile: introduce KSTRIPCMD to strip kernel modules
When sstrip is selected it tries to strip kernel modules too.
Unfortunately this fails with a "unrecognized program segment header
size" error thus interrupting the build process.
We introduce a new $(KSTRIPCMD) strip command for this, being a regular
strip when sstrip is selected and an empty stub when not stripping.
At the same time get rid of the REMOVE_SECTION_* variables, as they are
only used once.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -421,7 +421,7 @@ endif find $(TARGET_DIR) -type f -perm +111 '!' -name 'libthread_db*.so*' | \ xargs $(STRIPCMD) 2>/dev/null || true find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \ - xargs -r $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) + xargs -r $(KSTRIPCMD) || true mkdir -p $(TARGET_DIR)/etc # Mandatory configuration file and auxilliary cache directory |