summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-09-05 15:24:12 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-09-05 15:24:12 +0200
commit0642da781803160ec93a7b6d39bae921535d7c19 (patch)
tree7a94a4eb140d5f2a8b240ae2c50446a4f582eeb8 /Makefile
parent6538b1d1e719778d02830f4d3d2975c36e6555cf (diff)
parent4a37bf3b9eb6d34a3fb75140234c21417521ae17 (diff)
Merge branch 'qstrip' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 568348494..f2e349f27 100644
--- a/Makefile
+++ b/Makefile
@@ -40,6 +40,10 @@ else
BR2_LOCAL:=$(TOPDIR)/local
endif
+# Strip quotes and then whitespaces
+qstrip=$(strip $(subst ",,$(1)))
+#"))
+
# Variables for use in Make constructs
comma:=,
empty:=
@@ -369,8 +373,7 @@ endif
ifeq ($(BR2_ENABLE_LOCALE_PURGE),y)
LOCALE_WHITELIST=$(PROJECT_BUILD_DIR)/locales.nopurge
-LOCALE_NOPURGE=$(strip $(subst ",,$(BR2_ENABLE_LOCALE_WHITELIST)))
-#"))
+LOCALE_NOPURGE=$(call qstrip,$(BR2_ENABLE_LOCALE_WHITELIST))
target-purgelocales:
rm -f $(LOCALE_WHITELIST)