summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-31 10:19:50 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-09-16 20:28:25 +0200
commit18183726d4ab327b217a9ead3a8e88cb434257f6 (patch)
treed47124d1f74260dc461b43c9938709f3bf3f8972 /Makefile
parent397fe5cc0b091c997794d755d27a72848ad210ea (diff)
Remove the BOARD/LOCAL feature
This can be achieved by adding a new target in target/device/, and I will later propose a mechanism to add external boards and packages, so that our users not willing to get their target-specific or package-specific things merged can keep them cleanly separated from Buildroot tree. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 0 insertions, 15 deletions
diff --git a/Makefile b/Makefile
index 8adaff4c4..cfa57788c 100644
--- a/Makefile
+++ b/Makefile
@@ -32,14 +32,6 @@ noconfig_targets:=menuconfig xconfig config oldconfig randconfig \
defconfig allyesconfig allnoconfig release tags \
source-check help
-
-# Use shell variables, if defined
-ifneq ($(BUILDROOT_LOCAL),)
-BR2_LOCAL:=$(BUILDROOT_LOCAL)
-else
-BR2_LOCAL:=$(TOPDIR)/local
-endif
-
# Strip quotes and then whitespaces
qstrip=$(strip $(subst ",,$(1)))
#"))
@@ -52,20 +44,13 @@ space:=$(empty) $(empty)
# $(shell find . -name *_defconfig |sed 's/.*\///')
# Pull in the user's configuration file
ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
-ifeq ($(BOARD),)
-# if "make BOARD=xyz" command
-include .config
-else
-# if "make" command
--include $(BR2_LOCAL)/$(BOARD)/$(BOARD).config
-endif
endif
# Override BR2_DL_DIR if shell variable defined
ifneq ($(BUILDROOT_DL_DIR),)
BR2_DL_DIR:=$(BUILDROOT_DL_DIR)
endif
-LOCAL:=$(BR2_LOCAL)
# To put more focus on warnings, be less verbose as default
# Use 'make V=1' to see the full commands