diff options
author | Eric Andersen <andersen@codepoet.org> | 2003-03-04 19:16:19 +0000 |
---|---|---|
committer | Eric Andersen <andersen@codepoet.org> | 2003-03-04 19:16:19 +0000 |
commit | 1fc3f2f3de0f731c2869a48f951557eed6704218 (patch) | |
tree | e5fa011e92f78d0feab200dde260ba21561e76d0 /Makefile | |
parent | 36830baea210bba2490f643a1d147bf9adb2b62b (diff) |
Rework things to ensure we are cross compiling. Teach problematic
apps like openssh to cross compile. This eliminates the need for
the magic ld-uClibc.so.0 symlink in /lib
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 9 |
1 files changed, 9 insertions, 0 deletions
@@ -167,6 +167,15 @@ HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \ -e 's/cris.*/cris/' \ ) GNU_HOST_NAME:=$(HOST_ARCH)-pc-linux-gnu +TARGET_CONFIGURE_OPTS=PATH=$(TARGET_PATH) \ + AR=$(TARGET_CROSS)ar \ + AS=$(TARGET_CROSS)as \ + LD=$(TARGET_CROSS)ld \ + NM=$(TARGET_CROSS)nm \ + CC=$(TARGET_CROSS)gcc \ + GCC=$(TARGET_CROSS)gcc \ + CXX=$(TARGET_CROSS)g++ \ + RANLIB=$(TARGET_CROSS)ranlib all: world |