summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-10-29 21:00:26 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-10-29 21:00:26 +0200
commit3be496834375256f15cb98812d92f9b3d6fcb3a7 (patch)
tree6bed2ea24aa272d6f762928e5fdc41c7afe4471c /Makefile
parentdf3e367c5b6253ebb1ca2de6b97b662793bdb5f3 (diff)
Optimize (-O2) host binaries by default
Default HOST_CFLAGS to -O2, so host tools (like the cross compiler) are built with optimization by default. Based on a patch by Will Newton <will.newton@gmail.com>. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 0 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 22c3801d1..efc42ffc8 100644
--- a/Makefile
+++ b/Makefile
@@ -148,15 +148,6 @@ HOSTLD:=$(shell which $(HOSTLD) || type -p $(HOSTLD) || echo ld)
HOSTLN:=$(shell which $(HOSTLN) || type -p $(HOSTLN) || echo ln)
HOSTNM:=$(shell which $(HOSTNM) || type -p $(HOSTNM) || echo nm)
-ifndef CFLAGS_FOR_BUILD
-CFLAGS_FOR_BUILD:=-g -O2
-endif
-ifndef CXXFLAGS_FOR_BUILD
-CXXFLAGS_FOR_BUILD:=-g -O2
-endif
-ifndef FCFLAGS_FOR_BUILD
-FCFLAGS_FOR_BUILD:=-g -O2
-endif
export HOSTAR HOSTAS HOSTCC HOSTCXX HOSTFC HOSTLD
# bash prints the name of the directory on 'cd <dir>' if CDPATH is