summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-07-08 10:21:16 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-08 10:21:16 +0200
commit74708bad1512a917a28c59646d1f9491f6fe9ea6 (patch)
tree7f3bf126d8251e99dda6da042be1fe016d59e3c3 /Makefile
parent049cf426e32d6f789439d0d06905c977bfd25c02 (diff)
parentd0169fda2144ef5dfe25e801d58a227ed119a38c (diff)
Merge branch 'misc-fixes' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index df276c11b..d6bcb36f0 100644
--- a/Makefile
+++ b/Makefile
@@ -441,12 +441,12 @@ show-targets:
@echo $(TARGETS)
ifeq ($(BR2_CONFIG_CACHE),y)
-# drop configure cache if configuration is changed
-$(BUILD_DIR)/tgt-config.cache: $(CONFIG_DIR)/.config
+# drop configure caches if configuration is changed
+$(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache: $(CONFIG_DIR)/.config
rm -f $@
touch $@
-$(BASE_TARGETS): | $(BUILD_DIR)/tgt-config.cache
+$(BASE_TARGETS): | $(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache
endif
else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
@@ -580,7 +580,7 @@ endif
rm -rf $(CONFIG_DIR)/.config $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/.config.cmd $(CONFIG_DIR)/.auto.deps
flush:
- rm -f $(BUILD_DIR)/tgt-config.cache
+ rm -f $(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache
%_defconfig: $(TOPDIR)/configs/%_defconfig
cp $^ $(CONFIG_DIR)/.config