summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2003-11-11 06:49:26 +0000
committerManuel Novoa III <mjn3@codepoet.org>2003-11-11 06:49:26 +0000
commitf08097dd63b658c058ed56c3a039f0d447a0d94a (patch)
tree889e0b448415ad6def609cb62c6d473f7e070c77 /Makefile
parent2394ee58a97cf279ecb55176c5529421e2f32544 (diff)
Move uclibc-configured target forward so arch prompt happens sooner.
When locale support is desired, pass the correct option to gcc configure.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 05297fc79..a8f753124 100644
--- a/Makefile
+++ b/Makefile
@@ -83,8 +83,8 @@ OPTIMIZE_FOR_CPU=$(ARCH)
# -msoft-float flag. To avoid CFLAGS problems, you may want to use
# scripts similar to those in the build*/staging_dir/bin directory.
# Uncomment the next 2 lines to build a soft-float toolchain and rootfs.
-# SOFT_FLOAT_CONFIG_OPTION=--without-float
-# TARGET_SOFT_FLOAT=-msoft-float
+#SOFT_FLOAT_CONFIG_OPTION=--without-float
+#TARGET_SOFT_FLOAT=-msoft-float
TARGET_OPTIMIZATION=-Os
TARGET_DEBUGGING= #-g
@@ -117,7 +117,8 @@ ifeq ($(USE_UCLIBC_TOOLCHAIN),true)
ifeq ($(GCC_2_95_TOOLCHAIN),true)
TARGETS+=binutils uclibc-configured gcc2_95
else
-TARGETS+=binutils uclibc-configured gcc3_3
+#TARGETS+=binutils uclibc-configured gcc3_3
+TARGETS+=uclibc-configured binutils gcc3_3
endif
else
TARGETS+=uclibc
@@ -203,6 +204,9 @@ else
ARCH_FPU_SUFFIX:=_nofpu
endif
+ifeq ($(ENABLE_LOCALE),true)
+EXTRA_GCC_CONFIG_OPTIONS += --enable-clocale=gnu
+endif
HOSTCC:=gcc
BASE_DIR:=${shell pwd}