summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-07-27 12:37:30 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-07-27 12:37:30 +0000
commit153b1beaeb02e1d4780428c0387b7003644e402b (patch)
treebcccc4c78a3003a3c008555e355d7ad891e3e448 /Makefile
parent0c238e669f338d374e3140d77cb770301c45a978 (diff)
- fix building mconf with curses flags
- make sure to rm .config when the first 'make menuconfig' was interrupted and thus no .config.cmd was created.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 61c776da9..f06977797 100644
--- a/Makefile
+++ b/Makefile
@@ -320,9 +320,11 @@ $(CONFIG)/mconf:
menuconfig: $(CONFIG)/mconf
@-mkdir -p $(CONFIG)/buildroot-config
- @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
+ @if ! KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
- $(CONFIG)/mconf $(CONFIG_CONFIG_IN)
+ $(CONFIG)/mconf $(CONFIG_CONFIG_IN); then \
+ test -f .config.cmd || rm -f .config; \
+ fi
config: $(CONFIG)/conf
@-mkdir -p $(CONFIG)/buildroot-config