diff options
author | Peter Korsgaard <jacmet@sunsite.dk> | 2010-06-05 21:09:05 +0200 |
---|---|---|
committer | Peter Korsgaard <jacmet@sunsite.dk> | 2010-06-05 21:15:10 +0200 |
commit | 2b42aae78421127a37b7a5e9ae972276dc5c3779 (patch) | |
tree | 94a6c02ca8377fd610da5e5c871bc31fcdf7adf7 /Makefile | |
parent | 35fac17ebca566795bdd947033eedb5c5ea3a492 (diff) |
Makefile: support gconfig (GTK-based configurator) similar to xconfig
Support the GTK variant of the graphical kconfig configurator as an
alternative to the Qt3-based one.
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 11 |
1 files changed, 10 insertions, 1 deletions
@@ -29,7 +29,7 @@ CONFIG_DEFCONFIG=.defconfig CONFIG=package/config DATE:=$(shell date +%Y%m%d) -noconfig_targets:=menuconfig xconfig config oldconfig randconfig \ +noconfig_targets:=menuconfig gconfig xconfig config oldconfig randconfig \ defconfig allyesconfig allnoconfig release \ randpackageconfig allyespackageconfig allnopackageconfig \ source-check help @@ -484,6 +484,14 @@ xconfig: $(CONFIG)/qconf test -f .config.cmd || rm -f .config; \ fi +gconfig: $(CONFIG)/gconf + @mkdir -p $(CONFIG)/buildroot-config + @if ! KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \ + KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \ + $(CONFIG)/gconf $(CONFIG_CONFIG_IN); then \ + test -f .config.cmd || rm -f .config; \ + fi + menuconfig: $(CONFIG)/mconf @mkdir -p $(CONFIG)/buildroot-config @if ! KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \ @@ -605,6 +613,7 @@ help: @echo 'Configuration:' @echo ' menuconfig - interactive curses-based configurator' @echo ' xconfig - interactive Qt-based configurator' + @echo ' gconfig - interactive GTK-based configurator' @echo ' oldconfig - resolve any unresolved symbols in .config' @echo ' randconfig - New config with random answer to all options' @echo ' defconfig - New config with default answer to all options' |