diff options
author | Gustavo Zacarias <gustavo@zacarias.com.ar> | 2010-12-31 08:39:01 -0300 |
---|---|---|
committer | Peter Korsgaard <jacmet@sunsite.dk> | 2011-01-02 22:55:16 +0100 |
commit | 009407e6be898abedb308247a82e4dee525e6570 (patch) | |
tree | 7ca84272c3040e080bda4ca13a850a552e5bee3c /Makefile | |
parent | b25cf0a05c1146b8f09da0c73032f3e08f768d86 (diff) |
binutils: make it a proper package
* Convert binutils to a proper autotargets package
* Add version 2.21 and drop version 2.17
* Hook up packaged binutils for target gcc
* Build tools are on HOST_DIR now so change it
* Move cross/host gcc to HOST_DIR
* Drop kludge from commit 3c77bab2eeace3ee675bd745ca335fa3dd1630bb
This is fixed in the next commit "gcc: install copies of libgcc,
libstdc++ and libgcj to the sysroot" - tested for arm & x86_64
targets.
* TARGET_CROSS now pointed to HOST_DIR too
[Peter: Config.in tweaks]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -245,7 +245,7 @@ BASE_TARGETS += host-ccache endif ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y) -BASE_TARGETS += uclibc-configured binutils cross_compiler uclibc-target-utils kernel-headers +BASE_TARGETS += uclibc-configured host-binutils cross_compiler uclibc-target-utils kernel-headers else BASE_TARGETS += uclibc endif @@ -618,7 +618,7 @@ endif configured: dirs kernel-headers uclibc-config busybox-config linux26-config -prepatch: gcc-patched binutils-patched gdb-patched uclibc-patched +prepatch: gcc-patched gdb-patched uclibc-patched cross: $(BASE_TARGETS) |