diff options
author | Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> | 2007-08-21 11:25:30 +0000 |
---|---|---|
committer | Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> | 2007-08-21 11:25:30 +0000 |
commit | 7b403ada3715d1d6e510abbb6b4ccf89b2c09167 (patch) | |
tree | 381fb3e4cecf45363110f9510986c9c919d63d0e /Makefile | |
parent | f0ca4b8205242e3b6c2a302f0d254bb2085f76e2 (diff) |
- sed -i -e "/\-[[:space:]]*mkdir[[:space:]][[:space:]]*-p/s/-[[:space:]]*mkdir/mkdir/g"
(want to know about errors if mkdir failed). Thanks to Cristian Ionescu-Idbohrn for pointing this out
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 14 |
1 files changed, 7 insertions, 7 deletions
@@ -321,7 +321,7 @@ $(CONFIG)/mconf: fi menuconfig: $(CONFIG)/mconf - @-mkdir -p $(CONFIG)/buildroot-config + @mkdir -p $(CONFIG)/buildroot-config @if ! KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \ KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \ $(CONFIG)/mconf $(CONFIG_CONFIG_IN); then \ @@ -329,39 +329,39 @@ menuconfig: $(CONFIG)/mconf fi config: $(CONFIG)/conf - @-mkdir -p $(CONFIG)/buildroot-config + @mkdir -p $(CONFIG)/buildroot-config @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \ KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \ $(CONFIG)/conf $(CONFIG_CONFIG_IN) oldconfig: $(CONFIG)/conf - @-mkdir -p $(CONFIG)/buildroot-config + @mkdir -p $(CONFIG)/buildroot-config @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \ KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \ $(CONFIG)/conf -o $(CONFIG_CONFIG_IN) randconfig: $(CONFIG)/conf - @-mkdir -p $(CONFIG)/buildroot-config + @mkdir -p $(CONFIG)/buildroot-config @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \ KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \ $(CONFIG)/conf -r $(CONFIG_CONFIG_IN) allyesconfig: $(CONFIG)/conf cat $(CONFIG_DEFCONFIG) > .config - @-mkdir -p $(CONFIG)/buildroot-config + @mkdir -p $(CONFIG)/buildroot-config @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \ KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \ $(CONFIG)/conf -y $(CONFIG_CONFIG_IN) #sed -i -e "s/^CONFIG_DEBUG.*/# CONFIG_DEBUG is not set/" .config allnoconfig: $(CONFIG)/conf - @-mkdir -p $(CONFIG)/buildroot-config + @mkdir -p $(CONFIG)/buildroot-config @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \ KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \ $(CONFIG)/conf -n $(CONFIG_CONFIG_IN) defconfig: $(CONFIG)/conf - @-mkdir -p $(CONFIG)/buildroot-config + @mkdir -p $(CONFIG)/buildroot-config @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \ KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \ $(CONFIG)/conf -d $(CONFIG_CONFIG_IN) |