summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-09-10 13:04:12 +0000
committerEric Andersen <andersen@codepoet.org>2003-09-10 13:04:12 +0000
commit59759b8f44adb42d691dd964632304c38e59804e (patch)
tree04ad4727b170dd1522c9a0cc38a4f3852ad5b68e /Makefile
parenta2368356e722a9c40eee12585551e1e1571f41f2 (diff)
Default to using the kernel-headers package. mention dropbear.
Make rootfs be rootfs_$(ARCH)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 521debf4f..a9d8030b2 100644
--- a/Makefile
+++ b/Makefile
@@ -88,13 +88,16 @@ endif
# kernel you have already configured and you want to use that?
#TARGETS+=linux
#TARGETS+=user-mode-linux
-TARGETS+=system-linux
+#TARGETS+=system-linux
+TARGETS+=kernel-headers
# The default minimal set
TARGETS+=busybox tinylogin
# Openssh...
#TARGETS+=zlib openssl openssh
+# Dropbear sshd is much smaller than openssl + openssh
+#TARGETS+=dropbear_sshd
# Everything needed to build a full uClibc development system!
#TARGETS+=coreutils findutils bash make diffutils patch sed
@@ -160,7 +163,7 @@ TARGET_CROSS=$(STAGING_DIR)/bin/$(ARCH)-uclibc-
TARGET_CC=$(TARGET_CROSS)gcc
STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
#STRIP:=/bin/true
-IMAGE:=$(BASE_DIR)/root_fs
+IMAGE:=$(BASE_DIR)/root_fs_$(ARCH)
GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux
KERNEL_CROSS=$(STAGING_DIR)/bin/$(ARCH)-uclibc-
HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \