summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2006-06-22 02:24:08 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2006-06-22 02:24:08 +0000
commit0c1e709edbc2bed43a020e95f07b0be28437b55b (patch)
treede10bf645d22a59a340abe4f5371043a37a09e43 /Makefile
parent9399740475a555ccd941546a769aa94f8861ae47 (diff)
Resolves Bug #182 for buildroot. It works nice to pull in default
configuration files for targets. More information on the bug database page at <http://bugs.uclibc.org/view.php?id=182>.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 274e0e335..049b6e511 100644
--- a/Makefile
+++ b/Makefile
@@ -27,7 +27,8 @@ CONFIG_DEFCONFIG = .defconfig
CONFIG = package/config
noconfig_targets := menuconfig config oldconfig randconfig \
- defconfig allyesconfig allnoconfig release tags
+ defconfig allyesconfig allnoconfig release tags \
+ $(shell find . -name *_defconfig |sed 's/.*\///')
# Pull in the user's configuration file
ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
@@ -184,6 +185,10 @@ allnoconfig: $(CONFIG)/conf
defconfig: $(CONFIG)/conf
@$(CONFIG)/conf -d $(CONFIG_CONFIG_IN)
+%_defconfig: $(CONFIG)/conf
+ cp $(shell find . -name $@) .config
+ @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
+
#############################################################
#
# Cleanup and misc junk