summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-17 18:21:20 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-17 18:21:20 +0000
commitbb15c2215e6bd1b48a8db0e4d242fee491f774da (patch)
treea8d648677f61d9ce954ba96d5ad78d335b7dc340 /Makefile
parent7d0b7649c95c4e0525911d018fa03150b6639ee0 (diff)
more changes towards better board support
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 045aa19ef..d0cdb233a 100644
--- a/Makefile
+++ b/Makefile
@@ -109,9 +109,14 @@ $(STAGING_DIR):
@ln -sf ../lib $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib
$(TARGET_DIR):
- zcat target/default/skel.tar.gz | tar -C $(BUILD_DIR) -xf -
- cp -a target/default/target_skeleton/* $(TARGET_DIR)/
- -find $(TARGET_DIR) -type d -name .svn -exec rm -rf {} \; > /dev/null 2>&1
+ if [ -f "$(TARGET_SKELETON)" ] ; then \
+ zcat $(TARGET_SKELETON) | tar -C $(BUILD_DIR) -xf -; \
+ fi;
+ if [ -d "$(TARGET_SKEL_DIR)" ] ; then \
+ cp -a $(TARGET_SKEL_DIR)/* $(TARGET_DIR)/; \
+ fi;
+ -find $(TARGET_DIR) -type d -name CVS | xargs rm -rf
+ -find $(TARGET_DIR) -type d -name .svn | xargs rm -rf
source: $(TARGETS_SOURCE)