summaryrefslogtreecommitdiff
path: root/boot/yaboot/yaboot.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-14 18:20:45 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-10 21:05:12 +0200
commit649b5b92509dba021ed47ef4c04f358de83ba36f (patch)
treee0f22590fe9a99eba5565bbb4738b6f833b2c9fb /boot/yaboot/yaboot.mk
parent7c709f4affc44f3bbc9a09fec8d84ae3807e31e7 (diff)
bootloaders: move bootloader build code to boot/
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot/yaboot/yaboot.mk')
-rw-r--r--boot/yaboot/yaboot.mk44
1 files changed, 44 insertions, 0 deletions
diff --git a/boot/yaboot/yaboot.mk b/boot/yaboot/yaboot.mk
new file mode 100644
index 000000000..cbeae5086
--- /dev/null
+++ b/boot/yaboot/yaboot.mk
@@ -0,0 +1,44 @@
+ifeq ($(ARCH),powerpc)
+
+#############################################################
+#
+# yaboot
+#
+#############################################################
+
+YABOOT_SOURCE:=yaboot-1.3.13.tar.gz
+YABOOT_SITE:=http://penguinppc.org/bootloaders/yaboot
+YABOOT_DIR:=$(BUILD_DIR)/yaboot-1.3.13
+
+$(DL_DIR)/$(YABOOT_SOURCE):
+ $(call DOWNLOAD,$(YABOOT_SITE),$(YABOOT_SOURCE))
+
+yaboot-source: $(DL_DIR)/$(YABOOT_SOURCE)
+
+$(YABOOT_DIR)/Makefile: $(DL_DIR)/$(YABOOT_SOURCE)
+ $(ZCAT) $(DL_DIR)/$(YABOOT_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ touch -c $(YABOOT_DIR)/Makefile
+
+$(YABOOT_DIR)/second/yaboot: $(YABOOT_DIR)/Makefile
+ $(MAKE) -C $(YABOOT_DIR) CROSS=$(TARGET_CROSS)
+ touch -c $(YABOOT_DIR)/second/yaboot
+
+yaboot: $(YABOOT_DIR)/second/yaboot
+
+yaboot-clean:
+ $(MAKE) -C $(YABOOT_DIR) clean
+
+yaboot-dirclean:
+ rm -rf $(YABOOT_DIR)
+
+endif
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(BR2_TARGET_YABOOT),y)
+TARGETS+=yaboot
+endif
+