summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-07-26 16:14:41 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-26 16:14:41 +0200
commit3cd5174ed796400a9566c0ea52f3551cba52bfe0 (patch)
treedeef22037d45296d9944b6bf6a6b82fab5902e97 /boot
parent3da3c338773021406a76e17f37ba7b9c1650b8b4 (diff)
u-boot: add Marvell u-boot.kwb support
Marvell boards like the sheevaplug needs a special .kwb image format, so add an option for it similar to how we handle zImage/uImage/.. for the kernel. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot')
-rw-r--r--boot/u-boot/Config.in12
-rw-r--r--boot/u-boot/u-boot.mk8
2 files changed, 19 insertions, 1 deletions
diff --git a/boot/u-boot/Config.in b/boot/u-boot/Config.in
index d445145eb..ce79a8a5c 100644
--- a/boot/u-boot/Config.in
+++ b/boot/u-boot/Config.in
@@ -57,6 +57,18 @@ config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
Most users may leave this empty
+choice
+ prompt "U-Boot binary format"
+
+config BR2_TARGET_UBOOT_FORMAT_BIN
+ bool "u-boot.bin"
+
+config BR2_TARGET_UBOOT_FORMAT_KWB
+ depends on BR2_arm
+ bool "u-boot.kwb (Marvell)"
+
+endchoice
+
config BR2_TARGET_UBOOT_TOOL_MKIMAGE
bool "mkimage tool in target"
help
diff --git a/boot/u-boot/u-boot.mk b/boot/u-boot/u-boot.mk
index c21166fe7..60a4676dc 100644
--- a/boot/u-boot/u-boot.mk
+++ b/boot/u-boot/u-boot.mk
@@ -27,7 +27,13 @@ endif
U_BOOT_DIR:=$(BUILD_DIR)/u-boot-$(U_BOOT_VERSION)
U_BOOT_CAT:=$(BZCAT)
+
+ifeq ($(BR2_TARGET_UBOOT_FORMAT_KWB),y)
+U_BOOT_BIN:=u-boot.kwb
+U_BOOT_MAKE_OPT:=$(U_BOOT_BIN)
+else
U_BOOT_BIN:=u-boot.bin
+endif
MKIMAGE:=$(HOST_DIR)/usr/bin/mkimage
@@ -124,7 +130,7 @@ $(U_BOOT_DIR)/$(U_BOOT_BIN): $(U_BOOT_DIR)/.header_modified
LDFLAGS="$(TARGET_LDFLAGS)" \
$(U_BOOT_CONFIGURE_OPTS) \
$(MAKE) CROSS_COMPILE="$(TARGET_CROSS)" ARCH=$(U_BOOT_ARCH) \
- -C $(U_BOOT_DIR)
+ $(U_BOOT_MAKE_OPT) -C $(U_BOOT_DIR)
# Copy the result to the images/ directory
$(BINARIES_DIR)/$(U_BOOT_BIN): $(U_BOOT_DIR)/$(U_BOOT_BIN)