summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-11-04 17:21:28 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-04 19:26:27 +0100
commit2e869a7c0508f3dda96ed69f79c79c89ea4e6a5d (patch)
treed1f71182f5e0b726dc667160e2a38af85a940bf9 /fs
parent6871b16531e7d36fc02d095d31fb82b8a6b50fe0 (diff)
Remove INITRAMFS_TARGET variable
This used to be needed when the filesystem code was rewritten, but not the Linux compilation code. Now that the Linux compilation code has been rewritten, the mechanism to ensure that initramfs gets built *before* the kernel so that it can be integrated is different, and this INITRAMFS_TARGET variable is no longer used. See f507921d391bb2578261a9e45c003e72302dc67a for details. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs')
-rw-r--r--fs/initramfs/initramfs.mk6
1 files changed, 0 insertions, 6 deletions
diff --git a/fs/initramfs/initramfs.mk b/fs/initramfs/initramfs.mk
index 30969a4c9..dd6aa94ad 100644
--- a/fs/initramfs/initramfs.mk
+++ b/fs/initramfs/initramfs.mk
@@ -6,12 +6,6 @@
#
#############################################################
-ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y)
-INITRAMFS_TARGET:=initramfs-root
-else
-INITRAMFS_TARGET:= #nothing
-endif
-
define ROOTFS_INITRAMFS_INIT_SYMLINK
if [ ! -e $(TARGET_DIR)/init ]; then \
ln -s sbin/init $(TARGET_DIR)/init; \