summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-08-31 21:53:40 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-08-31 21:53:40 +0200
commit3975e30b991d42d4cc153b738742f962d8fda757 (patch)
treea0ab51760d625dc65cd8e8870430c26a1fffd1f5 /fs
parent31aa331d34a67dd5a819d9a78aa0e265ff0b8bf3 (diff)
fs/squashfs: fix image file permissions
Set image file permissions to 0644 like it was before the fs rework, instead of the rather unhelpful 0700 (E.G. when image is used for tftp). Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs')
-rw-r--r--fs/squashfs/squashfs.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index 6117de62a..aae22b6fd 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -19,7 +19,8 @@ endif
define ROOTFS_SQUASHFS_CMD
$(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend \
- $(ROOTFS_SQUASHFS_ARGS)
+ $(ROOTFS_SQUASHFS_ARGS) && \
+ chmod 0644 $$@
endef
$(eval $(call ROOTFS_TARGET,squashfs))