summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-08 13:56:19 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-22 21:20:27 +0200
commit100c09a53b8806b2281a93ad21744d26f68bcc6b (patch)
tree6c5a0c822d2a182f4f757320f39c2800d2dfeea3 /linux/linux.mk
parent0802370746a91943ec44cbd67363525f72c873e4 (diff)
linux: adjust kernel config according to the Buildroot configuration
We only adjust the configuration or ARM EABI and IPv6. The (more complicated) initramfs case is handled in a separate commit. The user is expected to take care of all other configuration details (like having Netfilter enabled to make iptables work, etc.) Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 8b83e3066..71d961603 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -85,6 +85,16 @@ ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
else ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
cp $(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE) $(@D)/.config
endif
+ifeq ($(BR2_ARM_EABI),y)
+ $(call KCONFIG_ENABLE_OPT,CONFIG_AEABI,$(@D)/.config)
+else
+ $(call KCONFIG_DISABLE_OPT,CONFIG_AEABI,$(@D)/.config)
+endif
+ifeq ($(BR2_INET_IPV6),y)
+ $(call KCONFIG_ENABLE_OPT,CONFIG_IPV6,$(@D)/.config)
+else
+ $(call KCONFIG_DISABLE_OPT,CONFIG_IPV6,$(@D)/.config)
+endif
$(TARGET_MAKE_ENV) $(MAKE) $(LINUX26_MAKE_FLAGS) -C $(@D) oldconfig
$(Q)touch $@