summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-11-19 22:38:05 -0500
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-11 01:41:00 +0100
commit56d387716a7f6f744b1db77c69d661051db6e9d0 (patch)
treef954804fc516abd2e2c192de19ef741c125afb53 /linux/linux.mk
parent862c928ce5e5161afdd4c359dcb6c74155244a82 (diff)
linux: set a few more initramfs opts for newer kernels
Building with linux-2.6.36 and initramfs support causes the build to pause while it prompts for newer options (uid/gid/compression). So have the build system inject the newer options into the linux config automatically. Older versions should just ignore these. Signed-off-by: Mike Frysinger <vapier@gentoo.org> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index feda4182c..ab90c03e4 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -106,6 +106,9 @@ ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y)
touch $(BINARIES_DIR)/rootfs.initramfs
$(call KCONFIG_ENABLE_OPT,CONFIG_BLK_DEV_INITRD,$(@D)/.config)
$(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_SOURCE,\"$(BINARIES_DIR)/rootfs.initramfs\",$(@D)/.config)
+ $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_UID,0,$(@D)/.config)
+ $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_GID,0,$(@D)/.config)
+ $(call KCONFIG_DISABLE_OPT,CONFIG_INITRAMFS_COMPRESSION_NONE,$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_INITRAMFS_COMPRESSION_GZIP,$(@D)/.config)
endif
$(TARGET_MAKE_ENV) $(MAKE) $(LINUX26_MAKE_FLAGS) -C $(@D) oldconfig